Вопрос по информатике:
Написать программу на Паскаль. Двумерный массив заполнить рандомно. Найти номера первых отрицательных элементов каждой строки(столбца)
- 03.07.2018 09:51
- Информатика
- remove_red_eye 5033
- thumb_up 50
Ответы и объяснения 1
//Pascal ABC.NET v3.1 сборка 1172
Const
n=4;
Var
ma:array[1..n,1..n] of integer;
i,j:integer;
begin
randomize;
for i:=1 to n do
begin
for j:=1 to n do
begin
ma[i,j]:=random(50)-20;
write(ma[i,j]:4);
end;
writeln;
end;
writeln('Сторки:');
for i:=1 to n do
begin
write(i,':');
for j:=1 to n do
if ma[i,j]<0 then
begin
writeln(j);
break;
end;
writeln;
end;
writeln('Столбцы:');
for j:=1 to n do
begin
write(j,':');
for i:=1 to n do
if ma[i,j]<0 then
begin
writeln(i);
break;
end;
writeln;
end;
end.
- 04.07.2018 17:19
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.