Вопрос по информатике:
Паскаль. Благодарю за помощь! С клавиатуры вводится символьная строка. Определите, сколько в ней цифр
- 17.11.2016 18:10
- Информатика
- remove_red_eye 15632
- thumb_up 18
Ответы и объяснения 2
Var s:string; k,i:integer;
begin
write('Введите строку:');
readln(s);
k:=0;
for i:=1 to length(s) do
if (s[i]>='0')and(s[i]<='9') then k:=k+1;
writeln('k = ',k);
end.
Пример:
Введите строку:
13 апреля 2016 г .
k = 6
- 18.11.2016 15:07
- thumb_up 50
// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
Write(ReadlnString('>').Where(c->c in ['0'..'9']).Count)
end.
Тестовое решение:
> Зде3сь спр14ята1ны 5 ци926ф5ры чи35сла8979 "пи"
15
- 19.11.2016 08:34
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.