Вопрос по информатике:
(PASCAL)
Написать программу, которая вычисляет сумму первых п целых
положительных целых чисел. Количество суммируемых чисел должно
вводиться во время работы программы. Ниже представлен рекомендуемый
вид экрана во время работы программы (данные, введенные пользователем,
выделены полужирным шрифтом).
Вычисление суммы положительных чисел.
Введите количество суммируемых чисел —> 20
Сумма первых 20 положительных чисел равна 210
- 01.04.2018 07:34
- Информатика
- remove_red_eye 1295
- thumb_up 26
Ответы и объяснения 1
Var
n, i, sum : integer;
begin
writeln('Введите количество суммируемых чисел');
readln(n);
sum := 0;
for i := 1 to n do
sum := sum + i;
writeln('Сумма первых ', n, ' положительных чисел равна ', sum);
end.
- 02.04.2018 06:46
- thumb_up 1
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.