Вопрос по информатике:
Составьте программу,по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных
чисел
(массив не использовать).Сделайте три варианта программы,используя операторы While,Repeat ,For.
- 19.01.2018 09:00
- Информатика
- remove_red_eye 5485
- thumb_up 14
Ответы и объяснения 2
Программа может выглядеть так:
uses Crt;
const n=10;
var a, i, Sum: integer;
Sred: real;
begin
ClrScr;
Sum:=0;
i:=1;
While i<=10 do
begin
Write ('a = ');
ReadLn(a);
Sum:=Sum+a;
i:=i+1;
end;
Sred:=Sum/n;
Writeln('Sred = ', Sred:6:2);
WriteLn;
Sum:=0;
i:=1;
repeat
Write ('a = ');
ReadLn(a);
Sum:=Sum+a;
i:=i+1;
until i>n;
Sred:=Sum/n;
Writeln('Sred = ', Sred:6:2);
WriteLn;
Sum:=0;
for i:=1 to n do
begin
Write ('a = ');
ReadLn(a);
Sum:=Sum+a;
end;
Sred:=Sum/n;
Writeln('Sred = ', Sred:6:2);
ReadLn;
end.
- 20.01.2018 22:16
- thumb_up 45
1. While:
var a,i,s:integer;
begin
s:=0;
i:=0;
while i<10 do
begin
i:=i+1;
write('a = ');
readln(a);
s:=s+a;
end;
writeln('Среднее арифметическое = ',s/10);
end.
2. Repeat
var a,i,s:integer;
begin
s:=0;
i:=0;
repeat
i:=i+1;
write('a = ');
readln(a);
s:=s+a;
until i=10;
writeln('Среднее арифметическое = ',s/10);
end.
3. For:
var a,i,s:integer;
begin
s:=0;
for i:=1 to 10 do
begin
write('a = ');
readln(a);
s:=s+a;
end;
writeln('Среднее арифметическое = ',s/10);
end.
Пример:
a = 4
a = 6
a = 9
a = 7
a = 1
a = 3
a = 6
a = 5
a = 4
a = 8
Среднее арифметическое = 5.3
- 22.01.2018 00:56
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.