Вопрос по информатике:
Составить программу нахождения количества положительных элементов в массиве из n вещественных чисел
- 05.11.2017 07:33
- Информатика
- remove_red_eye 671
- thumb_up 13
Ответы и объяснения 2
Const
max = 20;
var
arr : array [1..max] of real;
count, i : integer;
begin
for i := 1 to max do
arr[i] := random(100) - 50;
for i := 1 to max do
write(arr[i], ' ');
writeln();
for i := 1 to max do
if arr[i] > 0 then
count := count + 1;
writeln('Количество положительных чисел: ', count);
end.
- 06.11.2017 18:23
- thumb_up 15
// PascalABC.NET 3.1, сборка 1214 от 09.04.2016
begin
var a:=ArrRandomReal(ReadInteger('n='),-20,20);
a.Println;
Writeln('Положительных: ',a.Where(x->x>0).Count)
end.
Тестовое решение:
n= 7
-17.1342332089014 3.03964398011549 16.2039925512876 -6.95437877762801 13.9224117034685 -1.08502876995366 11.8818603045688
Положительных: 4
- 07.11.2017 12:49
- thumb_up 16
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.