Вопрос по информатике:
Составить программу на вход количества чисел,а затем вводятся сами числа. Составить программу для нахождения макс и мин из этих чисел.
Помогите. Каким образом делать, не знаю.
- 16.03.2018 21:35
- Информатика
- remove_red_eye 907
- thumb_up 45
Ответы и объяснения 1
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
var a,i,min,max,n:integer;
begin
write('Введите количество чисел ');
readln(n);
min:=MaxInt; //считаем, что мимнимальное - самое большое целое
max:=-MaxInt;//считаем, что максимальное - самое маленькое целое
for i:=1 to n do begin
readln(a);
if a>max then max:=a;
if a
writeln('Максимальное: ',max,' минимальное: ',min);
end.
Тестовое решение:
Введите количество чисел 5
23
12
44
10
15
Максимальное: 44 минимальное: 10
- 17.03.2018 08:54
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.