Вопрос по информатике:
Составить программу моделирования автомата
Автомат фиксировал температуру воздуха на протяжении тёплого осеннего месяца (30 дней). В конце месяца на дисплей вывел:
1. температуру каждого дня за весь месяц
2. минимальную и максимальную температуру месяца
3. среднюю температуру месяца
4. отклонение температуры каждого дня от среднего значения
- 06.09.2017 23:24
- Информатика
- remove_red_eye 7466
- thumb_up 5
Ответы и объяснения 1
Const n=30;
var a:array[1..n] of integer;
i,min,max,s:integer; sr:real;
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
begin
a[i]:=random(11)+10;
write(a[i]:6);
end;
writeln;
min:=a[1]; max:=a[1];
s:=a[1];
for i:=2 to n do
begin
if a[i]
s:=s+a[i];
end;
sr:=s/n;
writeln('min = ',min,' max = ',max,' sr = ',sr);
s:=0;
for i:=1 to n do write(a[i]-sr:6:1);
end.
Пример (для 10 дней):
Массив A:
11 16 19 15 13 19 11 16 17 17
min = 11 max = 19 sr = 15.4
-4.4 0.6 3.6 -0.4 -2.4 3.6 -4.4 0.6 1.6 1.6
- 07.09.2017 20:04
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.