Вопрос по информатике:
Пожалуйста! Напишите программу . Условие такое: вводится дата например 05.04.2016, программа должна вывести что сегодня 5 апреля 2016. Умоляю! Очень нужно!
- 10.01.2015 04:32
- Информатика
- remove_red_eye 15515
- thumb_up 14
Ответы и объяснения 2
Программа (не проверяет корректность введенных данных, т.е. работает правильно только в случае, если введена корректная дата в формате dd.mm.yyyy):
const months:array[1..12] of string=
('января','февраля','марта','апреля','мая','июня',
'июля','августа','сентября','октября','ноября','декабря');
var s,s1,month:string;
d,m,y,code:integer;
begin
write('Введите дату dd.mm.yyyy = '); readln(s);
Val(copy(s,1,2),d,code);
s1:=s;
delete(s1,1,3);
Val(copy(s1,1,2),m,code);
month:=months[m];
delete(s1,1,3);
Val(copy(s1,1,4),y,code);
writeln(d,' ',month,' ',y);
end.
Пример:
Введите дату dd.mm.yyyy = 05.04.2016
5 апреля 2016
- 11.01.2015 10:37
- thumb_up 15
Program dates;
var
date : string;
dd, mm, yy : string;
d, m, y : integer;
function strMonth(dt : integer) : string;
var
res : string;
begin
res:='';
case dt of
1 : res:=' января ';
2 : res:= ' февраля ';
3 : res:= ' марта ';
4 : res:= ' апреля ';
5 : res:= ' мая ';
6 : res:= ' июня ';
7 : res:= ' июля ';
8 : res:= ' августа ';
9 : res:= ' сентября ';
10 : res:= ' октября ';
11 : res:= ' ноября ';
12 : res:= ' декабря ';
end;
strMonth := res;
end;
begin
write('Введите дату:');
readln(date);
dd:=copy(date, 1, 2);
mm:=copy(date, 4, 2);
yy:=copy(date, 7, 4);
val(dd, d);
val(mm, m);
val(yy, y);
writeln('Сегодня ', d, strMonth(m), y, ' года');
end.
- 12.01.2015 21:47
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.