Вопрос по информатике:
Помогите, пожалуйста! Заранее спасибо!
Напишите программу вычисления наименьшего общего кратного следующих четырех чисел:36, 54, 18 и 15.
Используйте процедуру вычисления наибольшего общего делителя двух чисел
- 24.10.2016 11:19
- Информатика
- remove_red_eye 14391
- thumb_up 7
Ответы и объяснения 1
Для пары целых ненулевых чисел (a,b) существует соотношение
НОК(a,b)*НОД(a,b)=a*b
// PascalABC.NET 3.1, сборка 1213 от 04.04.2016
function gcd(a,b:integer):integer;
// НОД
begin
while b0 do begin a:=a mod b; Swap(a,b) end;
Result:=a
end;
function lcm(a,b:integer):=(a*b) div gcd(a,b); //НОК
begin
var a:=36;
var b:=54;
var c:=18;
var d:=15;
Writeln('НОК(',a,',',b,',',c,',',d,')=',
lcm(lcm(lcm(a,b),c),d))
end.
Тестовое решение:
НОК(36,54,18,15)=540
- 25.10.2016 21:53
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.