Вопрос по информатике:
Помогите плиз) информатика
Ввод 10 элементов массива случайным образом из диапазона от (-50,50). Посчитать кол-во отрицательных чисел. Написать программу
- 08.03.2018 09:19
- Информатика
- remove_red_eye 14074
- thumb_up 13
Ответы и объяснения 2
// PascalABC.NET 3.1, сборка 1211 от 31.03.2016
begin
var a:=ArrRandom(10,-50,50); a.Println;
Writeln('Отрицательных ',a.Where(x->x<0).Count)
end.
Тестовое решение:
37 -20 2 -13 10 9 -25 11 8 -3
Отрицательных 4
- 09.03.2018 05:54
- thumb_up 24
Var
a: array[1..10] of integer;
i, n: integer;
begin
for i := 1 to 10 do
begin
a[i] := random(101) - 50;
if a[i] < 0 then n := n + 1;
write(a[i]:4);
end;
writeln;
writeln('Количество отрицательных = ', n);
end.
Тестовое решение
30 1 -23 -36 15 -40 18 38 43 47
Количество отрицательных = 3
- 01.01.1970 00:00
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.