Вопрос по информатике:
Напишите программу в последовательности натуральных чисел определить сумму чисел кратных 5
- 21.11.2017 10:34
- Информатика
- remove_red_eye 7978
- thumb_up 13
Ответы и объяснения 2
Вроде так,не люблю Pascal,хотя вы не указали на чём писать)
program name;
uses crt;
var i,s,n:integer;
a: array [1..100] of integer;
begin
clrscr;
readln(n);
s:=0;
for i:=1 to n do begin
if a[i] mod 5= 0 then begin
s:=s+a[i];
end;
end;
writeln(s);
end.
- 22.11.2017 23:50
- thumb_up 6
Последовательность натуральных чисел бесконечно, поэтому также бесконечна будет искомая сумма. Для того, чтобы сделать задачу реальной, ограничимся n первыми членами последовательности, т.е. рядом чисел 1,2,3,..n.
В этом ряду первое число, кратное 5 - это 5. А дальше будем прибавлять по 5, пока не превысим числа n и все полученные числа складывать.
Вот очень короткое решение, написанное на самой современной версии языка Паскаль.
// PascalABC.NET 3.1, сборка 1211 от 31.03.2016
begin
Writeln(Range(5,ReadInteger('n='),5).Sum)
end.
Результат выполнения программы:
n= 100
1050
А вот решение на классическом "школьном" Паскале
var
i,n,s:integer;
begin
Write('n='); Read(n);
s:=0;
i:=5;
while i<=n do begin
s:=s+i;
i:=i+5
end;
Writeln(s)
end.
Можно без компьютера и программирования обойтись, если вспомнить об арифметической прогрессии.
Для нашего тестового примера получаем 100(100+5)/10=10*105=1050
- 23.11.2017 15:21
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.