Вопрос по информатике:
Написать программу,которая выведет все числа кратные 3 в диапазоне от 26 до 87
- 22.08.2016 01:51
- Информатика
- remove_red_eye 17775
- thumb_up 28
Ответы и объяснения 2
Решение №1 (через целочисленное деление)
var a: integer;
begin
a:=26;
repeat
if a mod 3 =0 then write(a:3);
a:=a+1;
until a >87;
end.
Решение №2 (без целочисленного деления)
Заметим, что первое число в данном диапазоне кратное 3 равно 27. Тогда каждое следуещее число на 3 больше предыдущего:
var a: integer;
begin
a:=27;
repeat
write(a:3);
a:=a+3;
until a >87;
end.
- 23.08.2016 21:43
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.