Вопрос по информатике:
Решить программу с помощью Паскаля. В автобусе помещается 160 пассажиров, три четверти мест находятся в салонах эконом- класса и одна четверть - в салоне бизнес-класса. Стоимость билета в салоне бизнес-класса составляет x рублей, что в два раза выше стоимости в салонах эконом-класса. Определить прибыль авиакомпании, если непроданных билетов эконом-класса осталось а и непроданных билетов бизнес-класса осталось b.
- 02.08.2018 05:19
- Информатика
- remove_red_eye 9539
- thumb_up 34
Ответы и объяснения 1
Летающий автобус)
1. Мест в эконом-классе 120, а в бизнес-классе 40.
2. 100 процентов прибыли получим, если заполним все места. Билет в эконом-классе стоит в 2 раза меньше чем X. Получаем следующее уравнение:
40*X + 0.5*120*X = 100%, X = 1% от всей прибыли. Значит один билет в бизнес - классе приносит один процент прибыли. А один билет в эконом-классе приносит 0.5 процента прибыли.
3. Осталось рассчитать прибыль компании учитывая непроданные билеты:
P = 100 - b - 0.5*a и написать программу:
var a,b:integer;
begin
repeat
writeln('Введите количество непроданных билетов (a,b)');
readln(a,b);
until (a<=120) and (b=0) and (b>=0);
writeln('Прибыль компании составит ',100-b-0.5*a,'%');
end.
- 03.08.2018 00:42
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.