Вопрос по информатике:
Написать программу для решения следующей задачи: найти среднее арифметическое наибольшего и наименьшего элементов данной конечной числовой последовательности. + блок-схема.
- 01.12.2016 02:05
- Информатика
- remove_red_eye 6143
- thumb_up 43
Ответы и объяснения 1
Программа:
const n=10;
var a:array[1..n] of integer;
i,max,min:integer;
begin
Randomize;
writeln('Массив a:');
for i:=1 to n do
begin
a[i]:=random(20);
write(a[i]:4);
end;
writeln;
max:=a[1]; min:=a[1];
for i:=1 to n do
begin
if a[i]>max then max:=a[i];
if a[i]
writeln('max = ',max,' min = ',min);
writeln('Среднее арифметическое = ',(max+min)/2);
end.
Пример:
Массив a:
18 8 6 13 15 14 16 6 2 16
max = 18 min = 2
Среднее арифметическое = 10
- 02.12.2016 00:33
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.