Вопрос по информатике:
Дан прямоугольник, длины сторон которого a и b являются натуральными числами.Определить, на сколько квадратов максимальной площади можно разделить данный прямоугольник,укажите их размеры.Составьте программу на паскале абс
- 26.12.2017 20:02
- Информатика
- remove_red_eye 6655
- thumb_up 12
Ответы и объяснения 1
Var a,b,c,d,nod,k:integer;
begin
write('a = '); readln(a);
write('b = '); readln(b);
c:=a; d:=b;
while (c>0)and(d>0) do
if c>d then c:=c mod d else d:=d mod c;
nod:=c+d;
k:=(a div nod)*(b div nod);
writeln(k,' квадратов размером ',nod,'x',nod);
end.
Пример:
a = 6
b = 15
10 квадратов размером 3x3
- 27.12.2017 11:18
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.