- 17.02.2018 18:57
- Информатика
- remove_red_eye 7466
- thumb_up 43
Ответы и объяснения 1
Фрагмент алгоритма описывает цикл. Выход из цикла тогда, когда не будет выполнено условие i<=5. По шагам это будет так:
i = 1 j = 2 s = 0
i = 2 j = 3 s = 3
i = 3 j = 4 s = 5
i = 4 j = 5 s = 7
i = 5 j = 6 s = 9
i = 6 j = 7 s = 11
Ответ: 11
Можно для проверки написать программу:
var i,j,s:integer;
begin
i:=1;j:=2;s:=0;
writeln('i = ',i,' j = ',j,' s = ',s);
repeat
s:=i+j;
j:=j+1;
i:=i+1;
writeln('i = ',i,' j = ',j,' s = ',s);
until i > 5;
end.
- 18.02.2018 21:26
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.