Вопрос по информатике:
Срочно помогите, прошу программу: Сельхозпредприятие реализует продукцию оптовым покупателям. Существует базовая цена реализации на каждый вид продукции. В зависимости от количества реализуемой продукции покупателям могут предоставляться скидки: если вес продукции больше 100 кг, предоставляется скидка 5%, если вес больше 300 кг, скидка составляет 10% от базовой цены. Составить программу определения стоимости реализуемой продукции, если известна базовая цена и количество продукции.
- 07.10.2017 12:31
- Информатика
- remove_red_eye 11111
- thumb_up 18
Ответы и объяснения 1
Var price, k, s: real;
begin
write('Цена: ');
readln(price);
write('Количество: ');
readln(k);
s:=price*k;
if (k>100) and (k<=3001) then s:=s*0.95;
if k>300 then s:=s*0.9;
writeln('Итого:', s);
end.
- 08.10.2017 09:24
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.