Вопрос по информатике:
Помогите, пожалуйста
Нужно написать программу позволяющую вводить оценки учеников в массиве.
Из чего должна состоять:
1) Количество учеников в классе
2) На основе запросить оценки каждого ученика
3) Должна вывести количество пятерок, четверок, троек и двоек
3) Успеваемость в процентах
(количество оценок (положительных 3,4,5)/количество учеников умножить на 100 процентов.
- 03.03.2016 00:53
- Информатика
- remove_red_eye 11563
- thumb_up 41
Ответы и объяснения 1
//Pascal ABC.NET v3.1 сборка 1172
var
ar: array of integer;
n, k2, k3, k4, k5, i: integer;
r: real;
begin
write('Сколько учеников?');
readln(n);
setlength(ar, n);
writeln('Введите оценки:');
for i := 0 to n - 1 do
begin
readln(ar[i]);
case ar[i] of
2: inc(k2);
3: inc(k3);
4: inc(k4);
5: inc(k5);
else
writeln('Не оценка');
exit;
end;
end;
writeln('2:', k2);
writeln('3:', k3);
writeln('4:', k4);
writeln('5:', k5);
write('Успеваемость=', (k3 + k4 + k5) / n * 100:0:1);
end.
Пример ввода:
Сколько учеников?6
Введите оценки:
2
2
3
4
5
5
Пример вывода:
2:2
3:1
4:1
5:2
Успеваемость=66.7
- 04.03.2016 05:32
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.