Вопрос по информатике:
Написать программу в паскале.
Удалить из строки все четырехбуквенные слова.
- 15.12.2016 19:19
- Информатика
- remove_red_eye 13450
- thumb_up 28
Ответы и объяснения 2
Var
S: string;
i, k: integer;
b: boolean;
begin
readln(s);
var n := Length(s);
i := 1;
repeat
b := true;
while (i <= n) and (s[i] ' ') do
begin
if b then
begin
k := i;
b := false
end;
inc(i)
end;
if i - k = 4 then
begin
delete(s, k, 5);
i := k;
n := n - 5
end
else inc(i)
until i > n;
write(s)
end.
- 16.12.2016 07:58
- thumb_up 35
//PascalABC.NET 3.1 сборка 1200
const
wordl = 4;
begin
var s := ReadlnString('s = ');
var s1 := '';
var i := 1;
repeat
var t := pos(' ', s, i + 1);
if ((s[i] = ' ') or (i = 1))
and (((t = 0) and (Length(s) - i = wordl)) or (t - i - 1 = wordl))
then
i := i + wordl + 1
else begin
s1 := s1 + s[i];
i := i + 1;
end;
until i > length(s);
writeln(s1)
end.
- 17.12.2016 23:03
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.