Вопрос по информатике:
Дана площадь квадрата. Составьте программу для вычисления его стороны и периметра.
Программу хорошую и понятную составить( в Паскале), все-таки баллов не мало
- 07.02.2018 23:51
- Информатика
- remove_red_eye 2394
- thumb_up 13
Ответы и объяснения 2
var
s, a, p: real;
begin
write('Введите площадь квадрата: ');
read(s);
a := sqrt(s); //Сторона
p := a * 4; //Периметр
writeln('Сторона квадрата = ', a : 0 : 2);
writeln('Периметр квадрата = ', p : 0 : 2);
end.
- 08.02.2018 06:35
- thumb_up 34
Var
s:real; //Могут быть и не целые числа
Begin
Write('Введите площадь квадрата ');
Readln(s);
Write('Сторона квадрата равна ',sqrt(s),', а периметр ',sqrt(s)*4); // sqrt - это квадратный корень (тобиш длина квадрата) а sqrt(s)*4 - это сторона квадрата умноженная на 4 стороны тобиш периметр
End.
- 09.02.2018 09:09
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.