Вопрос по информатике:
Помогите , пожалуйста:с
Мастям игральных карт присвоены порядковые номера: 1 — пики,2— трефы, 3 — бубны, 4 — червы. Достоинству карт, старших десятки, присвоены номера: 11 — валет, 12 — дама, 13 — король, 14 — туз. Даны два целых числа: N — достоинство (6 < N < 14) и M — масть карты (1 < M < 4). Вывести название соответствующей карты вида «шестерка бубен», «дама червей», «туз треф» и т. п. Нужно составить программу на Паскале
- 24.11.2017 00:37
- Информатика
- remove_red_eye 8453
- thumb_up 23
Ответы и объяснения 1
Var n,m:integer;
begin
write('N = '); readln(n);
write('M = '); readln(m);
case n of
6: write('шестерка ');
7: write('семерка ');
8: write('восьмерка ');
9: write('девятка ');
10: write('десятка ');
11: write('валет ');
12: write('дама ');
13: write('король ');
14: write('туз ');
else writeln('ошибка ввода '); end;
case m of
1: write('пик');
2: write('треф');
3: write('бубен');
4: write('червей');
else writeln('ошибка ввода '); end;
end.
Пример:
N = 10
M = 2
десятка треф
- 25.11.2017 09:28
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.