Вопрос по информатике:
1) К нам пришел заказчик. Он является судьей в баскетболе и попросил написать программу, которая бы считывала результаты каждой из 4-х четвертей баскетбольной встречи и говорила какая команда победила.
пример ввода:
26 : 17
13 : 15
19 : 11
14 : 16
ответ:
победила первая команда
предусмотреть возможность ничьи
Срочно!
- 02.03.2017 11:24
- Информатика
- remove_red_eye 19555
- thumb_up 6
Ответы и объяснения 1
// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
begin
var s1:=0;
var s2:=0;
for var i:=1 to 4 do begin
var a:=ReadlnString('Счет встречи № '+i).ToWords(Arr(':',' '));
s1+=StrToInt(a[0]); s2+=StrToInt(a[1])
end;
if s1>s2 then Writeln('победила первая команда')
else
if s1=s2 then Writeln('ничья')
else Writeln('победила вторая команда')
end.
Тестовое решение:
Счет встречи № 1 26:17
Счет встречи № 2 13 : 15
Счет встречи № 3 19: 11
Счет встречи № 4 14 :16
победила первая команда
- 03.03.2017 19:42
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.