Вопрос по информатике:
1.Составить программу вычисления суммы S=1+1/2+1/3+1/4+ | S= 1+1/2+1/3+1/4+1/n
2.Вычислите значения выражения (1+2) * (1+2+3) * (1+2+3+4) * (1+2+3+....10)
Решить в Pascal ABC.
- 16.08.2018 14:55
- Информатика
- remove_red_eye 848
- thumb_up 50
Ответы и объяснения 2
1.
var i,n:integer; s:real;
begin
write('n = '); readln(n);
s:=0;
for i:=1 to n do s:=s+1/i;
writeln('s = ',s);
end.
Пример:
n = 5
s = 2.28333333333333
2.
var x,a,s:real; i:integer;
begin
write('x = '); readln(x);
a:=x; s:=x; i:=1;
while i<11 do
begin
i:=i+2;
a:=x*x*a;
s:=a/i;
end;
writeln('s = ',s);
end.
Результат:
x = 3
s = 16104.2727272727
- 17.08.2018 12:07
- thumb_up 36
Program n1;
var a,n:integer;
s:real;
begin
s:=0;
write('введите число n : ');
readln(n);
for a:=1 to n do begin
s:=s+(1/a);
end;
writeln('сумма чисел от 1 до 1/',n,' = ',s);
end.
ввод :4;
вывод: 2.08333333333333;
program n2;
var s,pr:double;
a:integer; begin
s:=1;
pr:=1;
for a:=2 to 10 do begin
s:=s+a;
pr:=pr*s;
end;
writeln('pr = ',pr);
end.
вывод: pr = 141455160000
- 18.08.2018 01:04
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.