Вопрос по информатике:
Танк - машина специфическая. Поэтому при отборе в танкисты было принято решение не брать призывников с самым высоким и самым низким ростом. Вам дан рост каждого призывника. Посчитайте количество призывников, взятых в танкисты.
Формат ввода:
n – количество призывников (n <= 17)
a1 – рост первого призывника
a2 – рост второго призывника
...
an – рост n-ого призывника
Пример ввода:
5
120
150
190
120
170
Формат вывода:
kol - количество взятых в танкисты
Пример вывода:
2
- 23.08.2017 14:05
- Информатика
- remove_red_eye 17937
- thumb_up 8
Ответы и объяснения 1
/*
C++ compiler
gcc (Ubuntu 5.2.1-22ubuntu2) 5.2.1 20151010
Copyright (C) 2015 Free Software Foundation, Inc.
*/
#include
#include
using namespace std;
int main()
{
int count = 0;
cout <<"Введите количество призывников: ";
cin >>count;
if (count>17) count=17;
vector tanks(count);
for (unsigned i=0; i>tanks[i];
int min=300, max=0;
for (unsigned i=0; i
if (min>tanks[i]) min=tanks[i];
if (max
int cnt=0;
for (unsigned i=0; i
if ((tanks[i]!=min) and (tanks[i]!=max)) cnt++;
}
cout <
- 24.08.2017 19:14
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.