Вопрос по информатике:
2. Напишите программу вычисления в массиве из n элементов, заданных датчиком случайных чисел из промежутка от -13 до 25, количества четных элементов.
- 05.06.2018 02:12
- Информатика
- remove_red_eye 18759
- thumb_up 50
Ответы и объяснения 2
Const n = 10;
Var
i,k : Byte;
m : array[1..n] of Integer;
Begin
Randomize;
k:=0;
For i:=1 to n do
Begin
m[i]:=-13+Random(39);
Write(m[i],' ');
If not Odd(m[i]) then Inc(k);
end;
Writeln;
Writeln('Количество чётных элементов: ',k);
end.
- 06.06.2018 22:34
- thumb_up 41
// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
begin
var a:=ArrRandom(Readinteger('n='),-13,25); a.Println;
Writeln('k=',a.Where(x->x.IsEven).Count)
end.
Тестовое решение:
n= 15
17 20 22 -11 1 10 22 3 1 3 16 9 23 -8 15
k=6
- 07.06.2018 21:01
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.