Вопрос по информатике:
Вася построил забор из имеющихся досок разной длины. Если рядом стоящие доски отличаются не более чем на 10 сантиметров, Вася считает эту часть забора ровной. Сколько есть неровных частей у забора? Формат ввода: n – количество досок в заборе (n <= 20) a1 – длина первой доски a2 – длина второй доски ... an – длина n-ой доски Пример ввода: 7 15 30 25 30 40 29 21 Формат вывода: kol - количество Пример вывода: 2 Пояснение: Неровных частей 2: (15,30) и (40,29).
- 17.05.2018 12:05
- Информатика
- remove_red_eye 18008
- thumb_up 23
Ответы и объяснения 1
//PascalABC.Net 3.1 сборка 1200
begin
var a := ArrRandom(20, 10, 40);
var n := 0;
for var i := a.GetLowerBound(0) to a.GetUpperBound(0) - 1 do
if abs(a[i] - a[i + 1]) >= 10 then begin
n := n + 1;
writeln('(' + a[i] + ', ' + a[i + 1] + ')');
end;
writeln(n);
end.
- 18.05.2018 04:07
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.