Вопрос по информатике:
Pascal только! Помогите! Даю 30 баллов
Напишите программу, которая вводит координаты двух точек на числовой оси и выводит расстояние между ними.
Входные данные
В первой строке вводятся через пробел координаты первой точки (сначала x -координата, потом y -координата), во второй строке в том же порядке – координаты второй точки. Все координаты – вещественные числа.
Выходные данные
Программа должна вывести одно число: расстояние между точками с тремя знаками в дробной части.
------------------------------------------------------------------------------------------------------------------------------
входные данные
1. 1.
2. 2.
выходные данные
1.414
- 10.04.2017 18:43
- Информатика
- remove_red_eye 4612
- thumb_up 13
Ответы и объяснения 1
Var x1,y1,x2,y2,d: real;
begin
write('первая точка: x y'); readln(x1,y1);
write('вторая точка: x y'); readln(x2,y2);
d:=sqrt(sqr(x2-x1)+sqr(y2-y1));
writeln('расстояние: ',d);
end.
- 11.04.2017 14:42
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.