Вопрос по информатике:
Составить программу которая вычисляет произведение членов последовательности N натуральных чисел, кратных 5. Программа получает на вход целые числа, количество введеных чисел неизвестно, последовательность заканчивается числом N.
- 12.06.2018 16:42
- Информатика
- remove_red_eye 10775
- thumb_up 28
Ответы и объяснения 2
В условии задачи есть противоречие: с одной стороны количество чисел = N, а с другой - количество неизвестно, а дается признак конца последовательности. Программа дана для 2-го варианта.
var n,a:integer; p:real;
begin
write('n = '); readln(n);
write('a = '); readln(a);
p:=1;
while an do
begin
if a mod 5 = 0 then p:=p*a;
write('a = '); readln(a);
end;
writeln('p = ',p);
end.
Пример:
n = 999
a = 6
a = 10
a = 24
a = 15
a = 56
a = 7
a = 5
a = 999
p = 750
- 14.06.2018 10:35
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.