Вопрос по информатике:
Дано N случайных чисел в диапазоне от -3 до 3. Вычислите, сколько из них не совпадают с 0. Составить программу, используя цикл for. Для задания случайных ч исел используйте функцию random. N определяет пользователь. Числа вывести на экран.
- 18.12.2017 09:34
- Информатика
- remove_red_eye 655
- thumb_up 15
Ответы и объяснения 1
Var a,i,n,k : integer;
Begin
randomize;
Readln(n);
for i:=1 to n do begin
a:=random(7)-3;
if a=0 then k:=k+1;
writeln(i,' число = ',a);
end;
Writeln('Количество 0: ',k);
end.
- 19.12.2017 04:47
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.