Вопрос по информатике:
Нужно составить программу через процедуру в паскаль :
Каждая бактерия делится на две в течение одной минуты. В начальный момент имеется одна бактерия. Составьте программу, которая рассчитывает количество бактерий на заданное вами целое значение момента времени.
Через procedure
:(
- 18.04.2018 23:33
- Информатика
- remove_red_eye 7971
- thumb_up 32
Ответы и объяснения 1
Procedure copy_bacterium(time:integer);
var
i, bacterium:integer;
begin
bacterium:= 1;
for i:=1 to time do
bacterium:= bacterium * 2;
writeln(bacterium);
end;
var
n:integer;
begin
readln(n);
copy_bacterium(n);
end.
- 19.04.2018 03:36
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.