Вопрос по информатике:
Составить программу для c++ "Ввести возраст человека и вывести его вместе со словом ГОД,ГОДА,ЛЕТ(пример вам 1 год,вам 2 года,вам 55 лет)
- 14.01.2018 02:29
- Информатика
- remove_red_eye 12910
- thumb_up 46
Ответы и объяснения 1
#include
int main()
{
using namespace std;
system("chcp 1251 > nul"); //для кириллицы
int age;
cout << "Введите возраст: ";
cin >> age;
if (age > 4 && age < 21)
cout << age << " ЛЕТ" << endl;
else if (age % 10 == 1)
cout << age << " ГОД" << endl;
else if (age % 10 > 1 && age % 10 < 5)
cout << age << " ГОДА" << endl;
else
cout << age << " ЛЕТ" << endl;
return 0;
}
- 15.01.2018 20:04
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.