Вопрос по информатике:
Разработать модель задачи, составить алгоритм и написать программу для вычисления площади и гипотенузы равнобедренного прямоугольного треугольника, если известен его катет.
Помогите, пожалуйста
- 01.01.2018 03:34
- Информатика
- remove_red_eye 6262
- thumb_up 19
Ответы и объяснения 1
Модель:
Пусть a - катет треугольника,
тогда его площадь S=1/2 *a *a
гипотенуза c = √(a²+a²)
Программа:
var a,s,c:real;
begin
write('a='); readln(a);
s:=a*a/2;
c:=sqrt(2*a*a);
writeln('s=',s,' c=',c);
end.
Пример:
a=4
s=8 c=5.66
- 02.01.2018 19:50
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.