Вопрос по информатике:
Ниже записан алгоритм. Получив на вход число x, этот алгоритм печатает число M. Известно, что x > 100. Укажите наименьшее такое (т.е. большее 100) число x, при вводе которого алгоритм печатает 2.
Очень подробное решение пожалуйста
var x, L, M: integer;
begin
readln(x);
L := x - 12;
M := x + 12;
while L <> M do
if L > M then
L := L - M
else
M := M – L;
writeln(M);
end.
Очень подробное решение пожалуйста
- 12.02.2018 23:53
- Информатика
- remove_red_eye 9245
- thumb_up 23
Ответы и объяснения 1
106
function f(x: integer): integer;
var
L, M: integer;
begin
L := x - 12;
M := x + 12;
while L M do
if L > M then
L := L - M
else
M := M - L;
f := L;
end;
begin
var x := 100;
var r := 0;
repeat
x := x + 1;
r := f(x);
until r = 2;
writeln(x);
end.
- 13.02.2018 12:06
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.