Вопрос по информатике:
For k:=1 to n do
Напишите программу, которая в последовательности натуральных чисел определяет максимальное четное число.
Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется чётное число. Количество чисел не превышает 1000. Введенные числа не превышают 30000.
Программа должна вывести одно число - максимально чётное число.
- 26.10.2017 04:40
- Информатика
- remove_red_eye 3269
- thumb_up 30
Ответы и объяснения 1
Program p12;
type tab=array[1..1000] of 1..30000;
var t:tab;
i,max,n:integer;
begin
readln(n);
for i:=1 to n do
readln(t[i]);
for i:=1 to n do
if(t[i] mod 2=0) and (t[i]>max) then max:=t[i];
write(max);
end.
- 27.10.2017 01:44
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.