Вопрос по информатике:
Все сделать в Паскале. Дан массив из 12 элементов, в котором есть положительные и отрицательные чи сла (ноль тоже есть): а1=5, а2=4, а3=-3, а4=1, а5=0, а6=-4, а7=, а8=25, а9=-8, а10=-5, а11=-17, а12=-1. Составьте программу, в которой 1 вариант: Все отрицательные числа меняются на «1», все положительные на «-5», нулевые не трогаются. Вывести на экран исходный и полученный массив как в классе; Дополнительная оценка, если появляется дополнительная возможность ввода своих чисел с клавиатуры с клавиатуры.
- 16.09.2017 06:09
- Информатика
- remove_red_eye 15789
- thumb_up 29
Ответы и объяснения 1
Program mm;
var a:array[1..12] of integer;
begin
for i:=1 to 12 do begin
а[1]:=5;
а[2]:=4;
а[3]:=-3;
а[4]:=1;
а[5]:=0;
а[6]:=-4;
а[7]:=(у тебя не написано);
а[8]=25;
а[9]=-8;
a[10]=-5;
а[11]=-17;
а[12]=-1;
end;
writeln('Вот исходный массив');
for i:=1 to 12 do writeln('A[',i,']=',a[i]);
for i:=1 to 12 do begin
if (A[i]<0) then a[i]:=1;
if (a[i]>0) then a[i]:=-5;
end;
writeln('Вот полученный массив');
for i:=1 to 12 do writeln('A[',i,']=',a[i]);
writeln(' Введите 12 чисел');
for i:=1 to 12 do readln(A[i]); (это доп оценка)
end.
- 18.09.2017 00:42
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.