Вопрос по информатике:
Написать программу которая для заданного натурального числа n вычисляет сумму
1+1/1+2+1/1+2+3+···+1/1+2+···n в паскале .
- 16.03.2018 11:50
- Информатика
- remove_red_eye 14071
- thumb_up 22
Ответы и объяснения 2
Var s: real; n,sn,i: integer;begin write('n = '); readln(n); s:=0; sn:=0; for i:=1 to n do begin sn:=sn+i; s:=s+1/(sn); writeln(s); end; writeln('сумма ряда: ',s);end.
- 17.03.2018 09:49
- thumb_up 17
//PascalABC.NET (версия 3.1, сборка 1196 от 09.03.2016)
//Наверное здесь опечатки 1+1/1+2+1/1+2+3+···+1/1+2+···n скорее всего имелось ввиду так:
//1+1/(1+2)+1/(1+2+3)+···+1/(1+2+···n)
var i,n:integer;
s,s1:real;
begin
readln(n);
s:=0;s1:=0;
for i:=1 to n do begin
s1:=s1+i;
s:=s+1/s1;
end;
writeln (s);
end.
- 18.03.2018 10:51
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.