Вопрос по информатике:
Дано целое число. Определить сколько в нем цифр 5.
Написать программу в Паскаль АВС
- 12.12.2015 21:53
- Информатика
- remove_red_eye 7224
- thumb_up 30
Ответы и объяснения 2
Var ch, k: integer;
begin
k:=0;
readln(ch);
while ch>0 do begin
If ch mod 10 = 5 then
k:=k+1;
ch:=ch div 10;
end;
writeln(k);
end.
- 14.12.2015 00:00
- thumb_up 23
// PascalABC.NET 3.1, сборка 1192 от 07.03.2016
begin
Writeln('Количество пятерок в числе равно ',
ReadInteger('n=').ToString.Where(c->c='5').Count)
end.
Тестовое решение:
n= 3456453
Количество пятерок в числе равно 2
- 14.12.2015 12:02
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.