Вопрос по информатике:
1. Вывести ряд чисел 5, 14, 41, 122, 365 учитывая, что первый элемент массива равен 2
3. Дан целочисленный массив из 20 элементов. Элементы массива могут принимать целые значения от -10000 до 10000 включительно. Напишите программу, позволяющую найти и вывести количество пар элементов, в которых сумма элементов делится на 3, но не делится на 9. В данной задаче под парой подразумеваются два соседних элемента массива.
- 06.12.2017 12:10
- Информатика
- remove_red_eye 14662
- thumb_up 37
Ответы и объяснения 1
// PascalABC.NET 3.1, сборка 1192 от 07.03.2016
begin
SeqGen(ReadInteger('Кол-во='),2,x->3*x-1).Println
end.
Тестовое решение:
Кол-во= 10
2 5 14 41 122 365 1094 3281 9842 29525
// PascalABC.NET 3.1, сборка 1192 от 07.03.2016
begin
var a:=ArrRandom(20,-10000,10000); a.Println;
Writeln('Кол-во пар: ',a.Pairwise.
Where(x->((x.Item1+x.Item2) mod 3=0) and
((x.Item1+x.Item2) mod 90)).Println.Count)
end.
Тестовое решение:
-1932 -9879 3600 -6873 6098 -308 -3663 3180 257 4339 -778 -1245 -9361 -7036 -2972 5592 4844 87 -980 -4458
(-1932,-9879) (-9879,3600) (3600,-6873) (6098,-308) (-3663,3180) (257,4339) (4339,-778)
Кол-во пар: 7
- 07.12.2017 01:48
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.