Вопрос по информатике:
2. Напишите программу вычисления в массиве из n элементов, заданных датчиком случайных чисел из промежутка от -11 до 14, суммы всех чисел, кратных 3.
- 05.01.2017 20:44
- Информатика
- remove_red_eye 5199
- thumb_up 15
Ответы и объяснения 1
Такие задачи здесь разбирались уже много раз. Как вариант можно предложить такое решение:
//Pascal
const n = 100;
var a:array[1..n] of integer;
i,s,m:integer;
begin
readln(m);
s:=0;
for i:=1 to m do begin
a[i]:=random(26)-11;
if a[i] mod 3=0 then s:=s+a[i];
end;
writeln(s);
end.
- 06.01.2017 13:43
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.