Вопрос по информатике:
Паскаль
Даны натуральные числа n и k. Написать программу вычисления выражения
1^k+2^k+3^k+4^k+…+n^k
- 18.04.2018 00:58
- Информатика
- remove_red_eye 17295
- thumb_up 38
Ответы и объяснения 1
// PascalABC.NET 3.1, сборка 1190 от 05.03.2016
begin
var n:=ReadInteger('n=');
var k:=ReadInteger('k=');
var s:=Biginteger(0);
for var i:=2 to n do s+=Power(Biginteger(i),k);
Writeln('Сумма ',s+1)
end.
Тестовые решения:
n= 10
k= 30
Сумма 1043651859661187698792930519525
n= 5
k= 2
Сумма 55
n= 38
k= 67
Сумма 8400313720757760689953535296227476513296331784292134843927352320607786766609162308796108536127867158913721
- 19.04.2018 08:09
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.