Вопрос по информатике:
Составить алгоритм и написать программу:
Мальчик , продающий на улице газеты, зарабатывает F рублей на продаже каждой из первых 75 газет. На каждой из остальных газет он зарабатывает по Х копеек. Сколько заработает мальчик, если он продаст 133 газеты. (Ответ дать в рублях и копейках)
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 20.07.2015 16:37
- Информатика
- remove_red_eye 10170
- thumb_up 27
Ответы и объяснения 1
Var f,x,sr,sk:integer;
begin
write('f (руб) = '); readln(f);
write('x (коп) = '); readln(x);
sr:=75*f + (133-75)*x div 100;
sk:=(133-75)*x mod 100;
writeln('Заработок = ',sr,' руб ',sk,' коп');
end.
Пример:
f (руб) = 2
x (коп) = 40
Заработок = 173 руб 20 коп
- 22.07.2015 00:19
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.