Вопрос по информатике:
1) Определите значение переменной S после выполнения следующего фрагмента программы:
S:=5; i:=14;
while i > 1 do begin
S := S + i div 2;
i := i - 1;
end;
2) Определите, что будет напечатано в результате работы следующего фрагмента программы:
var k, s: integer;
begin
s:=0;
k:=1;
while s < 66 do begin
k:=k+3;
s:=s+k;
end;
write(k);
end.
3) Определите, что будет напечатано в результате работы следующего фрагмента программы:
var k, s: integer;
begin
s:=5;
k:=0;
while k < 15 do begin
k:=k+2;
s:=s+k;
end;
write(s);
end.
4) За¬пи¬ши¬те зна¬че¬ние пе¬ре¬мен¬ной s, по¬лу¬чен¬ное в ре¬зуль¬та¬те ра¬бо¬ты сле¬ду¬ю¬щей про¬грам¬мы. Текст про-грам¬мы при¬ведён на трёх язы¬ках про¬грам¬ми¬ро¬ва¬ния.
а) б)
Var s,k: integer;
Begin
s := 0;
for k := 3 to 8 do
s := s + 6;
writeln(s);
End.
Var s,k: integer;
Begin
s := 0;
for k := 8 to 12 do
s := s + 12;
writeln(s);
End.
- 18.04.2018 00:01
- Информатика
- remove_red_eye 6000
- thumb_up 17
Ответы и объяснения 1
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.