Вопрос по информатике:
Написать программу которая формирует случайным образом массив из 20 целых чисел лежащих в диапазоне от 0 до 1000 после чего на экран выводится сам массив в одну строку следующей строке номер максимального элемента пробел максимальный элемент
- 05.01.2017 08:50
- Информатика
- remove_red_eye 18480
- thumb_up 50
Ответы и объяснения 1
Так уже решал такую задачу:
const n=20;
var
a:array[1..n] of integer;
i,max,nmax:integer;
begin
max:=0;
for i:=1 to n do begin
a[i]:=random(1001);
if a[i] >max then begin
nmax:=i;
max:=a[i];
end;
write(a[i]:5);
end;
writeln;
writeln(nmax,' ',a[nmax]);
end.
- 06.01.2017 01:31
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.