Вопрос по информатике:
Напишите программу в Паскаль, которая получает день и номер месяца, а выводит количество дней, оставшихся до Нового Года. Считайте, что год невисокосный (365 дней). Учтите, что слово "дней" может иметь также формы "день" и "дня".
Пример:
Введите день и месяц: 25 12
Осталось 7 дней до Нового Года.
Пример:
Введите день и месяц: 1 1
Осталось 364 дня до Нового Года.
Пример:
Введите день и месяц: 31 2
Неверная дата.
- 01.12.2017 18:21
- Информатика
- remove_red_eye 2249
- thumb_up 29
Ответы и объяснения 1
//PascalABC
Uses System;
var day, month: integer;
begin
Read(day, month); var d := new DateTime(DateTime.Now.Year, month, day); var new_year := new DateTime(d.Year+1, 1, 1); Writeln((new_year - d).TotalDays); end.
- 02.12.2017 00:03
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.