Вопрос по информатике:
Пожалуйста, напишите программу, которая вводит натуральное число N и определяет является ли число N совершенным. в паскале
- 10.02.2018 00:40
- Информатика
- remove_red_eye 19852
- thumb_up 26
Ответы и объяснения 1
Совершенное число - натуральное число, равное сумме всех своих собственных делителей (то есть всех положительных делителей, отличных от самого числа).
//Pascal
var
n, s, i: integer;
begin
s := 0;
readln(n);
// Находим делители до n-1, увеличиваем сумму s на i,
// если i - делитель введенного числа
for i := 1 to n - 1 do
if n mod i = 0 then s := s + i;
if s = n then
writeln('cовершенное')
else
writeln('не совершенное');
end.
- 01.01.1970 00:00
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.