Вопрос по информатике:
Помогите, пожалуйста.
Нужно составить программу в Турбо Паскаль, которая находит минимальный элемент в массиве и ставит его на первое место, при этом все остальные элементы сдвигаются. Вывести на экран новый массив.
- 05.04.2015 15:30
- Информатика
- remove_red_eye 14102
- thumb_up 20
Ответы и объяснения 1
Const n = 10;
var a:array[1..n]of integer;
min,imin,i,oldmin:integer;
begin
//Заполнение массива значениями в диапазоне
//от -100 до 100
//и одновременно находим минимальный элемент элемент
min:=100;
for i:=1 to n do begin
a[i]:=random(201)-100;
if a[i]<= min then
begin
min:=a[i];
imin:=i;//Запомним index минимального
end;
write(a[i]:5);
end;
writeln;
//В цикле сдвигаем элементы массива
//до индекса минимального включительно на
//одну позицию вправо
for i:=imin downto 2 do
a[i]:=a[i-1];
a[1]:=min;
//вывод элементов массива
for i:=1 to n do write(a[i]:5);
end.
- 06.04.2015 23:51
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.