Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число: сумму всех чисел, кратных 6 и оканчивающихся на 4.
- 08.02.2018 01:49
- Информатика
- remove_red_eye 18358
- thumb_up 29
Ответы и объяснения 1
Var
n, c: integer;
begin
repeat
write('Число - ');
readln(n);
if ((n mod 6) = 0) and ((n mod 4) = 0) then
c := c + n;
until n = 0;
Write('Сумма всех чисел, кратных 6 и оканчивающихся на 4 равна ', c);
end.
- 09.02.2018 13:30
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.