Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число — максимальное число, кратное 4.
- 14.02.2018 11:46
- Информатика
- remove_red_eye 15679
- thumb_up 31
Ответы и объяснения 1
Не знаю, какой язык тебе нужен, но вот фрагмент на VB Console, он, наверное , должен быть понятен всем
dim a,k,n as integer
N = console.readline
For i as integer = 1 to N
a = console.readline
if a mod 4 = 0 and a > k then k = a
Next
Console.WriteLine(a)
- 15.02.2018 04:26
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.