Вопрос по информатике:
Укажите наименьшее пятизначное число x, при вводе которого алгоритм печатает 26391.
Паскаль:
var x, y, a, b: integer;
begin
readln(x);
a:=0; b:=0; y:=1;
while x > 0 do begin
if (x mod 10) mod 2 = 0
then
a:= a*10 + x mod 10
else begin
y:= y*10;
b:= b*10 + x mod 10
end;
x := x div 10
end;
a:= a*y + b
writeln(a);
end.
- 07.12.2017 14:12
- Информатика
- remove_red_eye 11258
- thumb_up 18
Ответы и объяснения 1
1. В приведенном коде ошибка. Не хватает ";" в третьей строке снизу.
2. Немного изменим ваш код и получим искомое значение x
Искомое число х = 16293
var
x, y, a, b, k: integer;
begin
k:=10000;
repeat
x:=k;
a := 0; b := 0; y := 1;
while x > 0 do
begin
if (x mod 10) mod 2 = 0
then
a := a * 10 + x mod 10
else begin
y := y * 10;
b := b * 10 + x mod 10
end;
x := x div 10
end;
a := a * y + b;
k := k + 1;
until a = 26391;
writeln(a:8, k-1:8);
end.
- 08.12.2017 07:09
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.