Вопрос по информатике:
Требовалось написать программу вычисления факториала числа n (факториал числа n есть произведение всех целых чисел от 1 до n). Программист торопился и написал программу неправильно. Ниже приведён фрагмент его программы, в котором содержится пять ошибок:
к := 1;
f := 0;
while k f:=f * k;
к:=к + 1
Найдите ошибки. Допишите необходимые операторы и выполните программу на компьютере.
Пример входных данных
Пример входных данных Пример выходных данных
Введите n> 5 5!=120
Введите n> 6 6!=720
- 26.05.2016 16:00
- Информатика
- remove_red_eye 2017
- thumb_up 14
Ответы и объяснения 1
Var n,k,f:integer;
begin
write('n='); readln(n);
k:=1;
f:=1;
while k<=n do
begin f:=f*k; k:=k+1; end;
writeln(n,'!=',f);
end.
- 27.05.2016 19:50
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.